如何仅在Nginx Web服务器中启用TLS1.2教程

SSL2.0和SSL3.0具有许多已知的漏洞,如POODLE(CVE-2014-3566),这就是为什么最新的浏览器已经删除了对这些易受攻击的协议的支持。建议你将服务器移至使用TLS版本,特别是TLS 1.2。本篇文章将介绍关于使用Nginx Web服务器启用TLS 1.2

仅在Nginx中启用TLS1.2

在服务器上的配置文件中编辑域的Nginx服务器块部分,并添加如下ssl_protocols设置。这将在Nginx服务器块中仅启用TLSv1.2协议。

 ssl_protocols TLSv1.2;

使用ssl的最简单nginx服务器块如下所示

server {
    listen 443 ssl;
    server_name example.com;

    ssl_protocols TLSv1.2;
    ssl_certificate /etc/pki/tls/cert.pem;
    ssl_certificate_key /etc/pki/tls/private/privkey.pem;

同时启用TLS 1.1和1.2

poodle漏洞从sslv3扩展到tls 1.0和1.1。因此,我们不建议将其用于生产服务器,但如果想为开发启用它的话。可以执行以下配置。

 ssl_protocols TLSv1.2 TLSv1.1;

更改配置文件后,重新启动nginx服务以应用新设置

版权声明:
作者:wanghaha
链接:http://www.aiii.vip/880.html
来源:诸葛修仙
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
< <上一篇
下一篇>>